We have been monitoring the system for a few hours and everything looks to be stable. If any customers are still facing issues, please contact our support team via support@ithelpdirect.com.
Posted Aug 28, 2025 - 22:03 UTC
Monitoring
A fix has been implemented and services are being restored
Posted Aug 28, 2025 - 14:03 UTC
Update
We are continuing to work on this and working as quickly as we can to restore service.
Posted Aug 28, 2025 - 11:17 UTC
Identified
We have identified an issue that is causing our systems to deny inbound and outbound calls. We are working as quickly as possible to get the issue rectified.
Posted Aug 28, 2025 - 09:57 UTC
This incident affected: Telecoms (UKSIP 1, UKSIP 2).