Google seem to have sorted our issues out as we are seeing emails now being received from our helpdesk
Posted Jan 30, 2026 - 01:34 UTC
Identified
We have identified an issue that is rejecting our emails to the google platform. we are awaiting google response. If you have not had a response to your ticket and your using google, please call our office for an update to your ticket, alternatively you can log in to the portal via cp.ithelpdirect.com
Posted Dec 31, 2025 - 14:54 UTC
This incident affects: ITHD Services (Support via Email).